In the popular plugin WP GDPR Compliance , a serious vulnerability was discovered. To secure the site, you need to upgrade to version 1.4.3 or higher.
Currently, hackers are actively attacking WP-sites with this plugin. All resources with an earlier version than 1.4.3 are at risk.
Due to the vulnerability, attackers are able to gain access to the site as an administrator, which allows them to make any changes.
According to one of the victims, the attacks are carried out automatically. Hackers use bots that crack a site through a vulnerability in the plugin, and then register accounts. After that, they start creating fraudulent pages.
According to the WPScan Vulnerability Database, the vulnerability “allows unauthenticated users to perform any actions and change any value of the database.”
You can install the revised version of the plugin by reference .
Recall that in December of this year, versions of PHP 5.6 and 7.0, which are used on 57.1% of WP sites, will stop receiving security updates. This means that next month the resources on which older versions are installed will become less protected.